Web Application outage

Started
Lasted 14min
Major outage

Affected components

  1. Web Application

Updates

RESOLVED

lasted 14min

The LettrLabs web application has recovered.

INVESTIGATING

14min earlier

The LettrLabs web application is unavailable. We are investigating.